Hatena::Groupugochara

Harimauの編集記録等

2012-02-11

グループ拡張用スクリプトなどなど

21:19

とりあえず掲示板拡張です。掲示板に貼り付けたものと同じです。

Firefox/Opera用にGreasemonkeyのスクリプトを置いておきます。GoogleChromeでもたぶん使えます。Firefoxの方はGreasemonkeyのアドオンをインストールしてからご利用ください。

こちらからダウンロード

no title

こちらを導入すると、

  1. トップページと掲示板一覧でのリンクがツリーではないものに書き換わります。
  2. ツリー表示の際に「続きを読み込む」と「子ツリーを全表示」のボタンを追加します。押すとその場で続きを読み込んで表示します。最後が...になっていて続きがありそうなものは「続きを読み込む」で、...になっていなくて、続きがない可能性があるものは「▼」になっています。

作ってみると(2)が意外とusefulなので、ページの一覧下に「うごキャラクラブ拡張スクリプト設定」というのが追加されているので、そこから(1)を無効にできます。

不具合とかあったらご連絡を。


そのほか近況報告

  • パソコンは再インストールで復旧
  • 私立受験終了。結果はまだ。残るは本命公立。
  • 高校いった後も忙しいだろうから、活動は細々と

SukaiSukai2012/02/12 00:57これは!!すごく便利です!さすがHarimauさん。
どうもありがとうございます!ありがたく使わせて頂きます。
パソコンが再インストールで解決して良かったですね。
私立の受験お疲れ様です。次は公立の受験ですか。応援してます!

takuyarei0takuyarei02012/02/12 03:40Google Chromeでは使い方がわからなかった...。
Firefoxをインストールするか。

harimau_tigrisharimau_tigris2012/02/12 13:38よかったです^^
>google chrome
たぶん、0.1.0.0のリンクをクリックするだけで拡張機能と同じようにインストールが始まるはずです。

tikyuujin2011tikyuujin20112012/02/12 21:47今までIEで活動してたけど、
chromeに乗り換えようかな?

fukuhiro0628fukuhiro06282012/02/14 11:33Chromeでもうまくいきました。
いつも、ありがとうございます。

公立の受験も応援してます!

takuyarei0takuyarei02012/02/15 00:26なるほど、リンククリックだったのですか。
クリックすると開始したようです。

SukaiSukai2012/02/15 18:39あれ。標準がツリー表示になってしまいます。
一番下の「うごキャラクラブ拡張スクリプト設定」を
クリックしてリスト表示を初期にしても適用されないです。
どのようにしたらいいでしょうか?
お忙しいところすみません。

harimau_tigrisharimau_tigris2012/02/16 19:34うーん、一度スクリプトを再インストールしてみてください。
右上かどこかのGreasemonkeyのアイコン(猿のやつ)からアンインストールして、もう一度私のサイトからインストールしてください。

あと、現在書き換えするページが以下の2つに完全に一致するときだけになっています。アドレスバーの表示がほかのURLになっているようなら教えてください。(/がついる場合といない場合ではちがうページとみなされます。)
http://ugochara.g.hatena.ne.jp/
http://ugochara.g.hatena.ne.jp/bbs

SukaiSukai2012/02/16 22:04ありがとうございます。再インストールしてみました。
しかし同じようです。色々試してみたところ、
掲示板の専用ページからならリスト表示になるんですが、
トップの掲示板リンクから行くとツリー表示になってしまうようです。

takuyarei0takuyarei02012/02/16 23:08httpsじゃだめなのか...。

takuyarei0takuyarei02012/02/16 23:46Google Chrome 17.0.963.46 mでは「うごキャラクラブ拡張スクリプト設定」のダイアログでOKをクリックするとツリー表示になってしまうようです。(リスト表示にしますか?という質問なのに)
キャンセルだと、リスト表示になってしまいます。

takuyarei0takuyarei02012/02/16 23:48...と思ったのですが、更新しないと反映されないようです。
とりあえずこのコメントはあえて削除せず残します。

harimau_tigrisharimau_tigris2012/02/17 16:40とりあえず、判定法を変えるだけ変えてみた、0.1.0.1をアップロードしました。
公開ページからインストールしてみてください。
あと、Firefoxのバージョンはいくつでしょうか。


>>takuyarei0さん
HTTPSにもたぶん対応しました。ブラウザがHTTPSで拡張の実行を許していれば実行できます。

SukaiSukai2012/02/17 18:45調整ありがとうございます。
Firefoxのバージョンを10.0.1から10.0.2に更新したら
正常に使用できるようになりました。ありがとうございます!

harimau_tigrisharimau_tigris2012/02/17 21:08>>Sukaiさん
原因はわからないですが、直ってよかったです。